Evotel - Welkom/Riebeeckstad/Odendaalsrus Outage – Incident details

Welkom experiencing partial outage

Welkom/Riebeeckstad/Odendaalsrus Outage

Resolved
Major outage
Started about 1 month agoLasted about 4 hours

Affected

Free State

Major outage from 2:23 PM to 6:11 PM

Odendaalsrus

Major outage from 2:23 PM to 6:11 PM

Riebeeckstad

Major outage from 2:23 PM to 6:11 PM

Welkom

Major outage from 2:23 PM to 6:11 PM

Updates
  • Resolved
    Resolved

    🚨Evotel Notice🚨

    Odendaalsrus

    Welkom

    Riebeekstad

    Service to the area has been restored. Thank you for your patience.

  • Investigating
    Investigating

    We are aware of the network disruption in the area. Our team is investigating the cause and working diligently to restore full service as soon as possible.

    Next update: 20:00