Scheduled for April 20, 2024 at 10:00 AM – 6:00 PM
Affects
KwaZulu-Natal
Under maintenance from 10:00 AM to 6:00 PM
Vryheid
Under maintenance from 10:00 AM to 6:00 PM
Completed
April 20, 2024 at 6:00 PMCompleted
April 20, 2024 at 6:00 PMMaintenance has completed successfully
In progress
April 20, 2024 at 10:00 AMIn progress
April 20, 2024 at 10:00 AMMaintenance is now in progress
Planned
April 20, 2024 at 10:00 AMPlanned
April 20, 2024 at 10:00 AM🚨Evotel Notice🚨
Vryheid - Maintenance
12:01 - 20:00
20 April 2024
Vryheid
All clients can expect downtime during this period. We apologise for the short notice, but we do not expect any disruptions to extend beyond this time. Thank you for your patience.