Service to Welkom has been restored. The last few clients will be contacted on a case-by-case basis. Thank you for your patience during this downtime
Update
Update
🚨Evotel Notice🚨
Welkom
We are aware of the break-in Welkom. Extensive damage has been found and our team is working to reconnect the break, they are actively splicing on-site
Next update: 8am
Update
Update
🚨Evotel Notice🚨
Welkom
We are aware of the break-in Welkom. Extensive damage has been found and our team is working to reconnect the break, they are actively splicing on-site
Next update: 9pm
Update
Update
🚨Evotel Notice🚨
Welkom
We are aware of the break-in Welkom. Extensive damage has been found and our team is working to reconnect the break, splicing has begun.
Next update: 7pm
Identified
Identified
🚨Evotel Notice🚨
Welkom
We are aware of the break in Welkom. Extensive damage has been found and our team is working to reconnect the network.
Next update: 4pm
Update
Update
🚨Evotel Notice🚨
Welkom
We are aware of the break-in Welkom. Our team is investigating the cause.
Next update: 4pm
Investigating
Investigating
🚨Evotel Notice🚨
Welkom
We are aware of the break in Welkom. Our team is investigating the cause.