Evotel - Middleburg Speed connectivity – Incident details

Middleburg Speed connectivity

Resolved
Degraded performance
Started about 2 months agoLasted 1 day

Affected

Mpumalanga

Degraded performance from 6:19 PM to 6:15 AM

Middelburg

Degraded performance from 6:19 PM to 6:15 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    🚨 Evotel Notice🚨

    Middleburg

    We are currently aware of speed and connectivity issues affecting our services in Middleburg. Our technical team is actively working on resolving the problem and restoring optimal network performance as soon as possible.

    We appreciate your patience