Evotel - Upington Speed Issues – Incident details

Upington Speed Issues

Resolved
Degraded performance
Started 26 days agoLasted about 4 hours

Affected

Northern Cape

Degraded performance from 8:45 AM to 12:34 PM

Upington

Degraded performance from 8:45 AM to 12:34 PM

Updates
  • Resolved
    Resolved

    🚨 Evotel Notice 🚨

    Upington

    Kindly note that the link has been restored and performance should be back to normal.

    Thank you for your patience!

  • Investigating
    Investigating

    🚨 Evotel Notice 🚨

    Upington

    We are aware that clients are experiencing speed issues. Our team is actively working on it.