Evotel - Rustenburg Break – Incident details

Postmasburg experiencing partial outage

Rustenburg Break

Resolved
Partial outage
Started 3 months agoLasted about 9 hours

Affected

North West

Partial outage from 5:48 AM to 2:25 PM

Bergsig

Partial outage from 5:48 AM to 2:25 PM

Updates
  • Resolved
    Resolved

    🚨Evotel Notice🚨

    Rustenburg

    The connection in your area has been resolved. Thank you for your patience!

  • Identified
    Identified

    🚨Evotel Notice🚨

    Rustenburg

    Technicians are experiencing delays on site due to the widespread power outage. We will provide updates when available.

    Next update: 5PM

  • Investigating
    Investigating

    🚨Evotel Notice🚨

    Rustenburg

    We are aware of the break in connection in Rustenburg. Technicians are investigating the cause and we hope to have connection restored shortly.

    Next update: 11am