Evotel - Upington – Incident details

Upington

Resolved
Operational
Started 2 months agoLasted about 14 hours

Affected

Northern Cape

Degraded performance from 5:26 PM to 7:13 AM

Upington

Degraded performance from 5:26 PM to 7:13 AM

Updates
  • Resolved
    Resolved

    🚨Evotel Notice🚨

    Upington

    All services in the area have been successfully restored. Thank you for your patience.

  • Investigating
    Investigating

    🚨Evotel Notice🚨

    Upington

    Your area is impacted by intermittent service. We apologise for these disruptions, and technicians are working to restore stability to the region as quickly as possible. Updates will be provided at the times indicated below:

    Next update: 8am or sooner.