Evotel - Postmasburg Outage – Incident details

Experiencing partial outage

Postmasburg Outage

Investigating
Major outage
Started about 1 hour ago

Affected

Northern Cape

Major outage from 5:02 PM to 12:00 AM

Postmasburg

Major outage from 5:02 PM to 12:00 AM

Updates
  • Update
    Update

    Technicians are still on site working at restoring connection to the area. Restoring service to the area is our top priority. We apologise for the inconvenience.

    Next update: 08:00

  • Investigating
    Investigating

    We are of the outage in the area. Technicians are on site working at restoring connection to the area.

    Next update: 20:00