Evotel - Witbank Break – Incident details

Witbank Break

Resolved
Partial outage
Started about 2 months agoLasted 3 days

Affected

Mpumalanga

Partial outage from 7:49 AM to 5:37 AM

Klipfontein

Partial outage from 7:49 AM to 5:37 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Repairs are ongoing.

  • Investigating
    Investigating

    🚨Evotel Notice🚨

    Witbank

    We are aware of the break affecting clients in Witbank.

    Our team is investigating the issue and we hope to have the connection restored soon. Thank you for your patience.

    Next update: 11am