Evotel - Middelburg Speed issues – Incident details

Middelburg Speed issues

Resolved
Major outage
Started about 1 month agoLasted about 12 hours

Affected

Mpumalanga

Major outage from 5:38 PM to 6:06 AM

Middelburg

Major outage from 5:38 PM to 6:06 AM

Updates
  • Resolved
    Resolved

    🚨Evotel Notice🚨

    Middleburg

    Service to Middleburg has been restored. Thank you for your patience during this downtime.

  • Investigating
    Investigating

    🚨 Evotel Notice🚨

    Middleburg

    We are currently aware of speed and connectivity issues affecting our services in Middleburg. Our technical team is actively working on resolving the problem and restoring optimal network performance as soon as possible.

    We appreciate your patience