Evotel - Middelburg Speed issues – Incident details

Middelburg Speed issues

Resolved
Degraded performance
Started 15 days agoLasted about 13 hours

Affected

Mpumalanga

Degraded performance from 4:56 PM to 5:53 AM

Middelburg

Degraded performance from 4:56 PM to 5:53 AM

Updates
  • Resolved
    Resolved

    🚨 Evotel Notice🚨

    Middleburg

    The speed and connectivity issues affecting our services in Middleburg has been resolved.

    We appreciate your patience.

  • Investigating
    Investigating

    🚨 Evotel Notice🚨

    Middleburg

    We are currently aware of speed and connectivity issues affecting our services in Middleburg. Our technical team is actively working on resolving the problem and restoring optimal network performance as soon as possible.

    We appreciate your patience.