Evotel - Lenasia South and Ennerdale – Incident details

Lenasia South and Ennerdale

Resolved
Degraded performance
Started 2 months agoLasted 5 days

Affected

Gauteng

Degraded performance from 12:27 PM to 4:47 AM

Lenasia

Degraded performance from 12:27 PM to 4:47 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Evotel Notice

    Ennerdale

    Lenasia South

    We are currently aware of speed and connectivity issues affecting our services in Ennerdale and Lenasia South. Our technical team is actively working on resolving the problem and restoring optimal network performance as soon as possible.

    We appreciate your patience.