Evotel - Upington Connectivity – Incident details

Upington Connectivity

Resolved
Degraded performance
Started about 2 months agoLasted 3 days

Affected

Northern Cape

Degraded performance from 5:54 PM to 11:16 AM

Upington

Degraded performance from 5:54 PM to 11:16 AM

Updates
  • Resolved
    Resolved

    🚨Evotel Notice🚨

    Upington

    The connection in your area has been resolved. Thank you for your patience

  • Investigating
    Investigating

    🚨 Evotel Notice🚨

    Upington

    We are currently aware of speed and connectivity issues affecting our services in Upington .Our technical team is actively working on resolving the problem and restoring optimal network performance as soon as possible.

    We appreciate your patience

    Next update 8am