The connection in your area has been resolved. Thank you for your patience!
Identified
Identified
🚨Evotel Notice🚨
Riebeeckstad
Technicians are aware of the outage in Riebeeckstad. Our technicians have identified the damaged cable, and our team is working actively on restoring the network
Next update: 2pm
Investigating
Investigating
🚨Evotel Notice🚨
Riebeeckstad
Technicians are aware of the outage in Riebeeckstad. Our technicians have identified the damaged cable, and our team is working actively on restoring the network