Evotel - Welkom Break – Incident details

Middelburg experiencing major outage

Welkom Break

Resolved
Partial outage
Started about 1 month agoLasted about 11 hours

Affected

Free State

Partial outage from 6:05 AM to 4:51 PM

Welkom

Partial outage from 6:05 AM to 4:51 PM

Updates
  • Resolved
    Resolved

    🚨 Evotel Notice🚨

    Welkom

    Connection to all affected clients have been restored and your patience is appreciated.

  • Update
    Update

    🚨Evotel Notice🚨

    Welkom

    Majority of the clients have been restored, the team is actively working on the complete repair on site.

    Next update: 8pm

  • Update
    Update

    🚨Evotel Notice🚨

    Welkom

    The team has identified a damaged feeder cable and is actively working on the repair.

    We hope to restore the connection soon!

    Next update: 5pm

  • Identified
    Identified

    🚨Evotel Notice🚨

    Welkom

    The team has identified a damaged feeder cable and is actively working on the repair.

    We hope to restore connection soon!

    Next update: 2pm

  • Investigating
    Investigating

    🚨Evotel Notice🚨

    Welkom

    We are aware of the break affecting connection in parts of Welkom. The team is investigating the cause and more information will be provided when available.

    Next update: 11AM or sooner.