Service to your area has been restored, thank you for your patience!
Identified
Identified
🚨Evotel Notice🚨
Witbank
Backhaul services to Witbank are being repaired. We are monitoring the progress of repairs, but we expect connection before this evening.
Next update: 5pm
Investigating
Investigating
🚨Evotel Notice🚨
Witbank
We are aware of the break affecting connection in parts of Witbank. The team is investigating the cause and more information will be provided when available.