Scheduled for October 30, 2024 at 10:00 PM – October 31, 2024 at 4:00 AM
Affects
North West
Under maintenance from 10:00 PM to 4:00 AM
Bergsig
Under maintenance from 10:00 PM to 4:00 AM
- Update October 31, 2024 at 5:42 AM
- Completed - October 31, 2024 at 5:42 AM- 🚨Evotel Emergency Maintenance🚨 - Rustenburg - Thursday, 31 October 2024 - 00:00-6:00am - Please note, that maintenance in your area has been successfully completed. The remaining that are still down will be handled on a case by case basis. - Thank you for your patience! 
 
- Completed October 31, 2024 at 4:00 AM
- Completed - October 31, 2024 at 4:00 AM- Maintenance has completed successfully 
 
- In progress October 30, 2024 at 10:00 PM
- In progress - October 30, 2024 at 10:00 PM- Maintenance is now in progress 
 
- Planned October 30, 2024 at 10:00 PM
- Planned - October 30, 2024 at 10:00 PM- 🚨Evotel Emergency Maintenance🚨 - Rustenburg - Thursday, 31 October 2024 - 00:00-6:00am - Please note, all clients in Rustenburg can expect downtime during this period. We apologise for the inconvenience caused. Any delays will be communicated.