External Services experiencing major outage

Postmasburg Planned Maintenance

Completed
Scheduled for November 24, 2023 at 10:01 PM – November 25, 2023 at 1:01 AM

Affects

Northern Cape
Postmasburg
Updates
  • Completed
    November 25, 2023 at 1:01 AM
    Completed
    November 25, 2023 at 1:01 AM

    Maintenance has completed successfully

  • In progress
    November 24, 2023 at 10:01 PM
    In progress
    November 24, 2023 at 10:01 PM

    Maintenance is now in progress

  • Planned
    November 24, 2023 at 10:01 PM
    Planned
    November 24, 2023 at 10:01 PM

    🚨 Network Maintenance🚨

    Postmasburg

    2023/11/25
    00:01-03:00

    Kindly note, downtime can be expected at the above mentioned times while maintenance is conducted on the network.

    Any delays will be communicated.