Evotel - Welkom Outage – Incident details

Experiencing partial outage

Welkom Outage

Resolved
Operational
Started 4 days agoLasted 7 minutes

Affected

Free State

Major outage from 6:09 PM to 6:16 PM

Welkom

Major outage from 6:09 PM to 6:16 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    🚨Evotel Notice🚨

    Welkom

    Our team is aware of the outage in Welkom. We are investigating the cause.

    Next update: 9PM.